通达信底背离选股公式

MACD 底背离的选股公式?

macd一般底背离是要结合个股的股价,还有图形进行分析的,才能知道底背离的程度。

通达信周线macd底背离盘中预警选股公式

你还在我十年前水平上

如何编写底背离选股公式

{macd底背离选股}
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
XG:FILTER(B1>0,5);

求通达信MACD绿柱底背离的选股公式

据我所知,不好办。因为macd的线决定了macd的柱,而macd的线值,是由股价的绝对数值决定的,于是,高价股和低价股,其绿柱的低位就有差异了。
绿柱的底背离,需要时间周期的确认,而时间周期,是需要用未来函数来确定的,而这个未来函数所取的周期数,对于不同的股来说,是不同的,于是就有了差异。多种差异的复合,导致无法绝对的产生符合条件的结果,总会有很多漏掉的,也会有很多不合条件的掺入。

谁能帮我编个macd底背离的选股公式,不盛感激!

MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIF,MID);
MACD:=(DIF-DEA)*2,COLORSTICK;
DIFF:=SUM(MA1-MA2,0);
SUMMACD:=SUM(MACD,0);
W1:=BARSLAST(CROSS(MA2,MA1))+1;
W2:=BARSLAST(CROSS(MA1,MA2))+1;
W3:=BARSLAST(CROSS(MACD,0))+1;
W4:=BARSLAST(CROSS(-MACD,0))+1;

趋度:IF(K,SUMMACD-REF(SUMMACD,MIN(W3,W4)),DIFF-REF(DIFF,MIN(W1,W2)));
趋势平均力度:趋度/IF(K,(MIN(W3,W4)+1)/20,(MIN(W1,W2)+1)/20),COLORSTICK;
MAX趋势平均力度:HHV(趋势平均力度,34);
MIN趋势平均力度:LLV(趋势平均力度,34);
--------------------------------------------------------------------------------------------------------------------------------------------
K值可调,调成“0”是通过均线缠绕面积判断背驰
调成“1”是通过macd面积判断背驰。
白线为均线(或macd )到目前为止的面积,白线的拐点(即某一段的最大值(绝对值))是均线或macd面积。如果K调成1,红绿柱为凭据趋度。

此指标不是选股指标,是个副图指标,因为选股指标需要判断前后面积的大小,难度极大,不易做出,目前还没发现有人能写出来。

MACD 底背离的选股公式?

macd一般底背离是要结合个股的股价,还有图形进行分析的,才能知道底背离的程度。