通达信指标修改

通达信指标修改?

首先你这不选近日涨停,没有未来函数,这条件是收盘价和不算今天前面的第5日收盘价比涨幅小于百分之20,这个条件不能保证近日不出现涨停,假设连续跌停4天涨停2天,今日收盘价除以5日前收盘价也符合涨幅小于百分之20日啊,但近期会有涨停.
再有你这变量AAA是个绘图结果,也不是选股结果啊
如果你是想写一个选股公式意思是前5日没有出现过涨停,今日ema10金叉ema21可以向下面这么写
XG:REF(SUM((C=H)*(C/REF(C,1)>1.097),5)=0,1)*(BARSLAST(EMA(CLOSE,10)<EMA(CLOSE,21))=1);

如何修改这个通达信指标?谢谢

A1:=MA(C,60);
AA:=A1>REF(A1,1);
BB:=EVERY(AA,10);
CC:=ABS(C/A1-1)<0.06;
DD:=C/REF(C,1)>1.04;
XG:BB AND CC AND DD;
你发的这三个公式不改也可以使用,为啥我都把你加了XG呢,这是因为,你建的选股公式,可以建成附图,再在K线图中调出来,那么满足条件的选股的地方就会出现一个白色的尖尖。加了XG后,可以使用技术指标选股,将XG的值设定为1即可。

关于通达信软件中的指标公式修改

只要你有完整的公式,导入或新建即可。
功能-专家系统-公式管理器-用户,选好类型,新建-确定。
新公式使用对应的平均移动线,不用自己修改。
例如公式使用4、12、62、133天均价线,你切换到这个指标时,看到的就是那4条线。

通达信指标更改

{如何别让谷峰挡住了后面的线}

JJA:=(((CLOSE - LLV(LOW,20)) / (HHV(HIGH,20) - LLV(LOW,20))) * 100);

AA98:=98,COLOR0000FF;

DRAWBAND(JJA,RGB(168,18,38),75,RGB(10,100,200));

DRAWBAND(JJA,RGB(168,18,38),25,RGB(10,100,200));

JJ:(((CLOSE - LLV(LOW,20)) / (HHV(HIGH,20) - LLV(LOW,20))) * 100);

A98:98,COLOR0000FF;

求大神写一个通达信交易系统的指标公式,自己有思路不知道怎么写

买入条件:当7日EMA上穿15日EMA时买入。 止损条件:当股价下跌到买入价减去买入价当日2倍ATR时止损,如果有加仓则加仓后止损条件按股价下跌到加仓价减去加仓价当日2倍ATR时止损 加仓条件:当股价每上涨买入价当日0.5倍ATR时加仓一次,最多加仓3次。 卖出条件:当7日EMA下穿15日EMA时卖出

通达信技术指标改选股公式?


  1. 依次点击菜单栏里的“功能”——公示系统——公式管理器——用户——条件选股公式——其它类型——新建,在打开的公式编辑器。

  2. 将下列源码复制后粘贴到中间文本框里,在上面的公式名称栏里写上公式名后,点“确定”,大功告成,得到满足公式中“J”条件的选股公式。

  3. 需要复制粘贴的源码:

  4. MH:=CLOSE#MONTH;

  5. ML:=CLOSE#MONTH;

  6. DZ:=(MH-C)/C*100>20 AND BARSCOUNT(CLOSE)>20;

  7. AB1:=EMA(C,14);

  8. AB1X:=(AB1-REF(AB1,1))/REF(AB1,1)*100;

  9. J:TFILTER(AB1X>=0,DZ,1);