通达信反弹黑马

麻烦哪位朋友帮我看看这公式有没有未来函数,并帮我改写为出现黑马信号时的通达信选股公式

VAR1:=EMA(CLOSE,3);
VAR2:=EMA(CLOSE,21);
VAR3:=BARSLAST(CROSS(VAR2,VAR1))>15;
VAR4:=VOL>MA(VOL,5)*2 AND VOL<MA(VOL,5)*5;
黑马:CROSS(VAR1,VAR2) AND VAR4 AND VAR3;

这公式无未来函数

恳请老师帮忙编写一通达信选股公式,当天出现大黑马的,非常感谢!

A5:=MA(C,5);
A10:=MA(C,10);
A20:=MA(C,20);
A30:=MA(C,30);
A60:=MA(C,60);
MAXA:=MAX(MAX(MAX(A5,10),MAX(A20,A30)),A60);
MINA:=MIN(MIN(MIN(A5,10),MIN(A20,A30)),A60);
MAXA/MINA<1.065 AND A5>REF(A5,1)AND A10>REF(A10,1)AND A20>REF(A20,1)AND A30>REF(A30,1);

麻烦哪位高手将下面公式改写为出现短线反弹的通达信选股公式

个股:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
短线反弹:CROSS(个股,9);

请高手将这个通达信出现“黑马”提示指标修改成选股公式。谢谢!

VARF:=TROUGHBARS(3,15,1)<4;
黑马:FILTER(VARF=1,3);

不过公式有未来,仅供参考。

求助,谁能提供杨百万的黑马指标,最好是通达信版的

N:=10;,F:=25;
VA6:=(2*CLOSE+HIGH+LOW)/4;
VA8:=LLV(LOW,34);
VARB:=HHV(HIGH,34);
VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
生命线:EMA(VARD,N), COLORFF00FF,LINICK2;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=((VAR2)/(VAR1))*(100)-70;
VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF((VAR9>100),VAR9-100,0);
VAR11:=HHV(HIGH,34);
B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);
B2:=EMA(B1,5);
STICKLINE(B1-B2>0,B1,B2,4,0),COLORFFFFFF;
STICKLINE(B1-B2<0,B1,B2,4,0),COLORFFFF52;
SS1:=(LOW+HIGH+CLOSE*2)/4;
SS2:= MA(SS1,4);
SS3:=HHV(SS2,10);
SS4:=MA(SS3,3);
SS5:=1.25*SS4-0.25*SS3;
XKKJ:=IF(SS5>SS3,SS3,SS5);
FF1:=LLV(SS2,10);
FF2:=MA(FF1,3);
FF3:=1.25*FF2-0.25*FF1;
DKKJ:=IF(FF3<FF1,FF1,FF3);
MA13:=MA(C,13);
ZDHM:=CROSS(C,DKKJ) AND CROSS(C,MA13) AND CROSS(C,XKKJ);
ZHM:=CROSS(C,MA13) AND CROSS(C,XKKJ);
大黑码:IF(ZDHM OR ZHM,50,0),COLORYELLOW,POINTDOT;
A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6) +13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12) +7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+ REF(A,20))/211;
D2:=EMA(D1,2); D3:=EMA(D2,2); K1:=EMA(D3,2);
小黑码:IF(CROSS(D1,K1),45,0),COLORFFCC66,POINTDOT;
STICKLINE(大黑码>0,0,大黑码*1.1,1,0),COLORWHITE;
STICKLINE(大黑码>0 AND 大黑码<52,30,大黑码,1,0),COLORRED;
STICKLINE(大黑码>0,0,大黑码*0.8,4,0),COLORRED; STICKLINE(大黑码>0,0,大黑码*0.4,8,0),COLORRED;
STICKLINE(大黑码>0,0,大黑码*0.2,10,0),COLORYELLOW; STICKLINE(大黑码>0,0,大黑码*0.1,10,0),COLORFFCC66;
STICKLINE(小黑码>0,0,小黑码*1.1,1,0),COLORWHITE; STICKLINE(小黑码>0 AND 小黑码<52,30,小黑码,1,0),COLORFFCC66;
STICKLINE(小黑码>0,0,小黑码*0.8,4,0),COLORFFCC66; STICKLINE(小黑码>0,0,小黑码*0.4,8,0),COLORFFCC66;

黑马实事求是的指标是个什么指标名字是他自己改的

说什么呢