MACD底背离选股公式

求通达信MACD绿柱底背离的选股公式

据我所知,不好办。因为macd的线决定了macd的柱,而macd的线值,是由股价的绝对数值决定的,于是,高价股和低价股,其绿柱的低位就有差异了。
绿柱的底背离,需要时间周期的确认,而时间周期,是需要用未来函数来确定的,而这个未来函数所取的周期数,对于不同的股来说,是不同的,于是就有了差异。多种差异的复合,导致无法绝对的产生符合条件的结果,总会有很多漏掉的,也会有很多不合条件的掺入。

求助老师:如何编写macd底背离的选股公式

{副图,供参考}

DIFF:EMA(C,12)-EMA(C,26);

DEA:EMA(DIFF,9);

MACD:2*(DIFF-DEA), COLORSTICK,LINICK2;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(C,A1+1)>C AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

STICKLINE(底背离,0,0.03,2.6,0),COLOR00FF00;

底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORFF00FF,LINICK2;

DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(C,A2+1)<C AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINICK2;

============================

{选股}

DIFF:=EMA(C,12)-EMA(C,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:REF(C,A1+1)>C AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

通达信周线macd底背离盘中预警选股公式

你还在我十年前水平上

求通达信15分钟周期MACD底背离的选股公式

用日线背离的就可以了。

求通达信日线MACD底背离选股公式

A1:=BARSLAST(REF(CROSS(MACD.DIF,MACD.DEA),1));
MACD底背:REF(C,A1+1)>C AND REF(MACD.DIF,A1+1)<MACD.DIF AND CROSS(MACD.DIF,MACD.DEA);

(以前次金叉股价与现在金叉股价相比)

通达信周线macd底背离盘中预警选股公式

你还在我十年前水平上