macd顶背离公式指标

MACD背离指标通达信指标公式源码

没有资金门槛的,只要你够买一手便可。

求大智慧MACD底背离和顶背离公式

说句实话我也想找这个公式,希望你早点找到,是个好指标。

求 通达信 MACD 顶背离 和 顶部二次背离 选股公式:

SQX:=(C-MA(CLOSE,13))*100; DIFF:EMA(MA(SQX,7),1),COLOR00FFFF; DEA:EMA(DIFF,7),COLORFF33FF; MACD:(DIFF-DEA)*2,COLORSTICK; 低位金叉:IF(CROSS(DIFF,DEA) AND DIFF<-0.1,0.3,0),COLORYELLOW,POINTDOT; STICKLINE(低位金叉,0,15,8,0),COLORYELLOW;DRAWICON(低位金叉,0.3,1); JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0)); 二次金叉:IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,0.2,0),COLORFF00FF,POINTDOT; STICKLINE(二次金叉,30,15,8,0),COLORFF00FF; A1:=BARSLAST(REF(CROSS(DIFF,DEA),1)); 底背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),0.1,0),COLORRED,POINTDOT; STICKLINE(底背离,45,30,8,0),COLORRED;DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED; A2:=BARSLAST(REF(CROSS(DEA,DIFF),1)); 顶背离:REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),COLORGREEN; DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN; A3:=CROSS(DIFF,DEA) AND DEA<0; 零下二次金叉:IF(FILTER(COUNT(A3,21)=2,10),0.05,0),COLORWHITE,POINTDOT; STICKLINE(零下二次金叉,45,60,8,0),COLORWHITE;

如何理解MACD 顶背离指标的使用

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
忽略以上公式。 当股价处于高位时,还在向上,MACD已经开始下行了。
这个时候就要注意,及时出货。

求通达信日线MACD底背离选股公式

A1:=BARSLAST(REF(CROSS(MACD.DIF,MACD.DEA),1));
MACD底背:REF(C,A1+1)>C AND REF(MACD.DIF,A1+1)<MACD.DIF AND CROSS(MACD.DIF,MACD.DEA);

(以前次金叉股价与现在金叉股价相比)

求助老师:如何编写macd底背离的选股公式

{副图,供参考}

DIFF:EMA(C,12)-EMA(C,26);

DEA:EMA(DIFF,9);

MACD:2*(DIFF-DEA), COLORSTICK,LINICK2;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(C,A1+1)>C AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

STICKLINE(底背离,0,0.03,2.6,0),COLOR00FF00;

底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORFF00FF,LINICK2;

DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(C,A2+1)<C AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINICK2;

============================

{选股}

DIFF:=EMA(C,12)-EMA(C,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:REF(C,A1+1)>C AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);